VS:IFC GetPsetName

From Vectorworks Developer
Revision as of 10:03, 27 October 2014 by Sasha (talk | contribs)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the name of the property set at that index

PROCEDURE IFC_GetPsetName(
hObject :HANDLE;
inPsetIndex :INTEGER;
VAR outStrPsetName :STRING;
RETURN :BOOLEAN);
def vs.IFC_GetPsetName(hObject, inPsetIndex, RETURN):
    return outStrPsetName

Parameters

hObject HANDLE Handle to object
inPsetIndex INTEGER of the property
outStrPsetName STRING Name of the pset
RETURN BOOLEAN

Remarks

Return Values

TRUE on success, FALSE indicates failure – incorrect handle, the object has no IFC data, index out of range.

Use this function in conjunction with IFC_GetNumPsets. If inPsetIndex = 1, the function will return the name of the first pset, attached to the object.

Example

VectorScript

PROCEDURE Test;
VAR
	hObject : HANDLE;
	outStrPsetName : STRING;
	ok : BOOLEAN;
BEGIN
	hObject := FSActLayer;
	IFC_GetPsetName(hObject, 1, outStrPsetName, ok);
	AlrtDialog(outStrPsetName);
END;

RUN(Test);

Python

hObject = vs.FSActLayer()
ok = False
outStrPsetName = vs. IFC_GetPsetName(hObject, 1, ok)
vs.AlrtDialog(outStrPsetName);

Version

Availability: from Vectorworks 2014