VS:IFC GetPsetName: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
(One intermediate revision by the same user not shown)
Line 10: Line 10:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
PROCEDURE IFC_GetPsetName(hObject:HANDLE; inPsetIndex:INTEGER; VAR outStrPsetName:STRING; RETURN:BOOLEAN);
FUNCTION IFC_GetPsetName(hObject:HANDLE; inPsetIndex:INTEGER; VAR outStrPsetName:STRING) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.IFC_GetPsetName(hObject, inPsetIndex, RETURN):
def vs.IFC_GetPsetName(hObject, inPsetIndex):
     return outStrPsetName
     return ok, outStrPsetName
</funcDef>
</funcDef>
</def>
</def>
Line 35: Line 35:
STRING
STRING
Name of the pset
Name of the pset
</line>
<line>
RETURN
BOOLEAN
</line>
</line>
</lineList>
</lineList>
Line 45: Line 40:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<return>
===== Return Values =====
TRUE on success, FALSE indicates failure – incorrect handle, the object has no IFC data, index out of range.
TRUE on success, FALSE indicates failure – incorrect handle, the object has no IFC data, index out of range.


Use this function in conjunction with IFC_GetNumPsets. If inPsetIndex = 1, the function will return the name of the first pset, attached to the object.
Use this function in conjunction with IFC_GetNumPsets. If inPsetIndex = 1, the function will return the name of the first pset, attached to the object.
</remark>
</return>
 
-----------------------------------------------------------------------------------------------------------
<remark></remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 63: Line 60:
BEGIN
BEGIN
hObject := FSActLayer;
hObject := FSActLayer;
IFC_GetPsetName(hObject, 1, outStrPsetName, ok);
ok := IFC_GetPsetName(hObject, 1, outStrPsetName);
AlrtDialog(outStrPsetName);
AlrtDialog(outStrPsetName);
END;
END;
Line 72: Line 69:
<code lang="py">
<code lang="py">
hObject = vs.FSActLayer()
hObject = vs.FSActLayer()
ok = False
ok, outStrPsetName = vs. IFC_GetPsetName(hObject, 1)
outStrPsetName = vs. IFC_GetPsetName(hObject, 1, ok)
if ok:
vs.AlrtDialog(outStrPsetName);
vs.AlrtDialog(outStrPsetName)
 
</code>
</code>
</sample>
</sample>

Latest revision as of 08:59, 17 December 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the name of the property set at that index

FUNCTION IFC_GetPsetName(
hObject :HANDLE;
inPsetIndex :INTEGER;
VAR outStrPsetName :STRING) : BOOLEAN;
def vs.IFC_GetPsetName(hObject, inPsetIndex):
    return ok, outStrPsetName

Parameters

hObject HANDLE Handle to object
inPsetIndex INTEGER of the property
outStrPsetName STRING Name of the pset

Return Value

TRUE on success, FALSE indicates failure – incorrect handle, the object has no IFC data, index out of range.

Use this function in conjunction with IFC_GetNumPsets. If inPsetIndex = 1, the function will return the name of the first pset, attached to the object.

Example

VectorScript

PROCEDURE Test;
VAR
	hObject : HANDLE;
	outStrPsetName : STRING;
	ok : BOOLEAN;
BEGIN
	hObject := FSActLayer;
	ok := IFC_GetPsetName(hObject, 1, outStrPsetName);
	AlrtDialog(outStrPsetName);
END;

RUN(Test);

Python

hObject = vs.FSActLayer()
ok, outStrPsetName = vs. IFC_GetPsetName(hObject, 1)
if ok:
	vs.AlrtDialog(outStrPsetName)

Version

Availability: from Vectorworks 2014