VS:IFC GetNumPsets2

From Vectorworks Developer
Revision as of 05:49, 31 January 2021 by CBM-c- (talk | contribs) (fix typos)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the number of property sets, attached to the object.

FUNCTION IFC_GetNumPsets2(
hObject :HANDLE;
bAllPsets :BOOLEAN;
VAR outNumPsets :INTEGER) : BOOLEAN;
def vs.IFC_GetNumPsets2(hObject, bAllPsets):
    return (BOOLEAN, outNumPsets)

Parameters

hObject HANDLE Handle to object.
bAllPsets BOOLEAN Include in the list the PSets from IFC Data Mapping.
outNumPsets INTEGER Number of PSets.

Example

VectorScript

PROCEDURE Test;
VAR
	numPSets : INTEGER;
	ok : BOOLEAN;
BEGIN
	ok := IFC_GetNumPsets2(FSActLayer, TRUE, numPSets);
	AlrtDialog(Concat('The number of PSets is ', numPSets));
END;

RUN(Test);

Python

numPSets = 0
ok, numPSets = vs.IFC_GetNumPsets2(vs.FSActLayer(), True)
vs.AlrtDialog('The number of PSets is ' + str(numPSets))

Version

Availability: from Vectorworks 2018