VS:IFC GetNumPsets2: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (fixed Python capital)
m (fix typos)
 
Line 56: Line 56:
BEGIN
BEGIN
ok := IFC_GetNumPsets2(FSActLayer, TRUE, numPSets);
ok := IFC_GetNumPsets2(FSActLayer, TRUE, numPSets);
AlrtDialog(Concat('The nummber of PSets is ', numPSets));
AlrtDialog(Concat('The number of PSets is ', numPSets));
END;
END;


Line 65: Line 65:
numPSets = 0
numPSets = 0
ok, numPSets = vs.IFC_GetNumPsets2(vs.FSActLayer(), True)
ok, numPSets = vs.IFC_GetNumPsets2(vs.FSActLayer(), True)
vs.AlrtDialog('The nummber of PSets is ' + str(numPSets))
vs.AlrtDialog('The number of PSets is ' + str(numPSets))
</code>
</code>
</sample>
</sample>

Latest revision as of 05:49, 31 January 2021

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the number of property sets, attached to the object.

FUNCTION IFC_GetNumPsets2(
hObject :HANDLE;
bAllPsets :BOOLEAN;
VAR outNumPsets :INTEGER) : BOOLEAN;
def vs.IFC_GetNumPsets2(hObject, bAllPsets):
    return (BOOLEAN, outNumPsets)

Parameters

hObject HANDLE Handle to object.
bAllPsets BOOLEAN Include in the list the PSets from IFC Data Mapping.
outNumPsets INTEGER Number of PSets.

Example

VectorScript

PROCEDURE Test;
VAR
	numPSets : INTEGER;
	ok : BOOLEAN;
BEGIN
	ok := IFC_GetNumPsets2(FSActLayer, TRUE, numPSets);
	AlrtDialog(Concat('The number of PSets is ', numPSets));
END;

RUN(Test);

Python

numPSets = 0
ok, numPSets = vs.IFC_GetNumPsets2(vs.FSActLayer(), True)
vs.AlrtDialog('The number of PSets is ' + str(numPSets))

Version

Availability: from Vectorworks 2018