VS:IFC GetNumPsets2: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Returns the number of psets for the specified ifc type.</desc>
Gets the number of property sets, attached to the object.</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 25: Line 25:
hObject
hObject
HANDLE
HANDLE
 
Handle to object.
</line>
</line>
<line>
<line>
Line 35: Line 35:
outNumPsets
outNumPsets
INTEGER
INTEGER
 
Number of PSets.
</line>
</line>
</lineList>
</lineList>

Revision as of 08:10, 28 January 2019

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the number of property sets, attached to the object.

FUNCTION IFC_GetNumPsets2(
hObject :HANDLE;
bAllPsets :BOOLEAN;
VAR outNumPsets :INTEGER) : BOOLEAN;
def vs.IFC_GetNumPsets2(hObject, bAllPsets):
    return (BOOLEAN, outNumPsets)

Parameters

hObject HANDLE Handle to object.
bAllPsets BOOLEAN
outNumPsets INTEGER Number of PSets.

Version

Availability: from Vectorworks 2018