VS:IFC GetNumPsets2: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
m (fix typos)
 
(4 intermediate revisions by 2 users not shown)
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Returns the number of psets for the specified ifc type.</desc>
Gets the number of property sets, attached to the object.</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 25: Line 25:
hObject
hObject
HANDLE
HANDLE
 
Handle to object.
</line>
</line>
<line>
<line>
bAllPsets
bAllPsets
BOOLEAN
BOOLEAN
 
Include in the list the PSets from IFC Data Mapping.
</line>
</line>
<line>
<line>
outNumPsets
outNumPsets
INTEGER
INTEGER
 
Number of PSets.
</line>
</line>
</lineList>
</lineList>
</params>
</params>
-----------------------------------------------------------------------------------------------------------
<return></return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 44: Line 47:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample></sample>
<sample>
==== VectorScript ====
<code lang="pas">
PROCEDURE Test;
VAR
numPSets : INTEGER;
ok : BOOLEAN;
BEGIN
ok := IFC_GetNumPsets2(FSActLayer, TRUE, numPSets);
AlrtDialog(Concat('The number of PSets is ', numPSets));
END;
 
RUN(Test);
</code>
==== Python ====
<code lang="py">
numPSets = 0
ok, numPSets = vs.IFC_GetNumPsets2(vs.FSActLayer(), True)
vs.AlrtDialog('The number of PSets is ' + str(numPSets))
</code>
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 05:49, 31 January 2021

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the number of property sets, attached to the object.

FUNCTION IFC_GetNumPsets2(
hObject :HANDLE;
bAllPsets :BOOLEAN;
VAR outNumPsets :INTEGER) : BOOLEAN;
def vs.IFC_GetNumPsets2(hObject, bAllPsets):
    return (BOOLEAN, outNumPsets)

Parameters

hObject HANDLE Handle to object.
bAllPsets BOOLEAN Include in the list the PSets from IFC Data Mapping.
outNumPsets INTEGER Number of PSets.

Example

VectorScript

PROCEDURE Test;
VAR
	numPSets : INTEGER;
	ok : BOOLEAN;
BEGIN
	ok := IFC_GetNumPsets2(FSActLayer, TRUE, numPSets);
	AlrtDialog(Concat('The number of PSets is ', numPSets));
END;

RUN(Test);

Python

numPSets = 0
ok, numPSets = vs.IFC_GetNumPsets2(vs.FSActLayer(), True)
vs.AlrtDialog('The number of PSets is ' + str(numPSets))

Version

Availability: from Vectorworks 2018