VS:IFC GetNumPsets

From Vectorworks Developer
Revision as of 08:58, 17 December 2018 by Sasha (talk | contribs)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the number of property sets, attached to the object

FUNCTION IFC_GetNumPsets(
hObject :HANDLE;
VAR outNumPsets :INTEGER) : BOOLEAN;
def vs.IFC_GetNumPsets(hObject):
    return (BOOLEAN, outNumPsets)

Parameters

hObject HANDLE Handle to object
outNumPsets INTEGER Number of Psets

Return Value

TRUE on success, FALSE indicates failure – incorrect handle, the object has no IFC data.

Example

VectorScript

PROCEDURE Test;
VAR
	hObject : HANDLE;
	iNum : INTEGER;
	ok : BOOLEAN;
begin
	hObject := FSActLayer;
	ok := IFC_GetNumPsets(hObject, iNum);
	AlrtDialog(Concat(iNum));
end;

Run(Test);

Python

ok, iNum = vs.IFC_GetNumPsets(vs.FSActLayer())
vs.AlrtDialog(str(iNum))

Version

Availability: from Vectorworks 2014