VS:IFC GetNumPsets: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 35: Line 35:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<return>TRUE on success, FALSE indicates failure – incorrect handle, the object has no IFC data.</return>
===== Return Values =====
TRUE on success, FALSE indicates failure – incorrect handle, the object has no IFC data.


</remark>
-----------------------------------------------------------------------------------------------------------
<remark></remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 08:58, 17 December 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the number of property sets, attached to the object

FUNCTION IFC_GetNumPsets(
hObject :HANDLE;
VAR outNumPsets :INTEGER) : BOOLEAN;
def vs.IFC_GetNumPsets(hObject):
    return (BOOLEAN, outNumPsets)

Parameters

hObject HANDLE Handle to object
outNumPsets INTEGER Number of Psets

Return Value

TRUE on success, FALSE indicates failure – incorrect handle, the object has no IFC data.

Example

VectorScript

PROCEDURE Test;
VAR
	hObject : HANDLE;
	iNum : INTEGER;
	ok : BOOLEAN;
begin
	hObject := FSActLayer;
	ok := IFC_GetNumPsets(hObject, iNum);
	AlrtDialog(Concat(iNum));
end;

Run(Test);

Python

ok, iNum = vs.IFC_GetNumPsets(vs.FSActLayer())
vs.AlrtDialog(str(iNum))

Version

Availability: from Vectorworks 2014