VS:IFC GetIFCEntity

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

This function gets IFC entity name for the given object.

FUNCTION IFC_GetIFCEntity(
hObject :HANDLE;
VAR outStrName :STRING) : BOOLEAN;
def vs.IFC_GetIFCEntity(hObject):
    return (BOOLEAN, outStrName)

Parameters

hObject HANDLE Handle to object
outStrName STRING Name of the IFC entity

Return Value

TRUE on success, FALSE indicates failure – incorrect handle or the object has no IFC data.

Example

Try to get the IFC entity name for the given object:

VectorScript

PROCEDURE Test;
VAR
	strName : STRING;
	hObject : HANDLE;
	ok : BOOLEAN;
begin
	hObject := FSActLayer;
	ok := IFC_GetIFCEntity(hObject, strName);
	AlrtDialog(strName);
end;

Run(Test);

Python

hObject = vs.FSActLayer()
ok, strName = vs.IFC_GetIFCEntity(hObject)
vs.AlrtDialog(strName)

Version

Availability: from Vectorworks 2014