VS:IFC GetIFCEntity

From Vectorworks Developer
Revision as of 14:34, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

This function gets IFC entity name for the given object.

FUNCTION IFC_GetIFCEntity(
hObject  : HANDLE;
VAR outStrName  : STRING) : BOOLEAN;
def vs.IFC_GetIFCEntity(hObject):
    return (BOOLEAN, outStrName)

Parameters

hObject HANDLE
outStrName STRING

Return Value

TRUE on success, FALSE indicates failure – incorrect handle or the object has no IFC data;

Remarks

None;

Example

Try to get the IFC entity name for the given object:

IFC_GetIFCEntity(hObject, strName);

Version

Availability: 2010