VS:IFC GetEntityProp2: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 49: Line 49:
</lineList>
</lineList>
</params>
</params>
-----------------------------------------------------------------------------------------------------------
<return></return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 08:57, 17 December 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the property value, its type and if the value comes from mapping or by instance.

FUNCTION IFC_GetEntityProp2(
hObject :HANDLE;
propertyName :STRING;
VAR outPropValue :STRING;
VAR outType :INTEGER;
VAR outMap :INTEGER) : BOOLEAN;
def vs.IFC_GetEntityProp2(hObject, propertyName):
    return (BOOLEAN, outPropValue, outType, outMap)

Parameters

hObject HANDLE
propertyName STRING
outPropValue STRING
outType INTEGER
outMap INTEGER

Version

Availability: from Vectorworks 2018