VS:IFC GetEntityProp

From Vectorworks Developer
Revision as of 17:36, 18 September 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the value and type of a selected property from the IFC entity

FUNCTION IFC_GetEntityProp(
hObject :HANDLE;
inStrPropName :STRING;
VAR outStrPropValue :STRING;
VAR outTypeSelect :INTEGER) : BOOLEAN;
def vs.IFC_GetEntityProp(hObject, inStrPropName):
    return (BOOLEAN, outStrPropValue, outTypeSelect)

Parameters

hObject HANDLE
inStrPropName STRING
outStrPropValue STRING
outTypeSelect INTEGER

Version

Availability: from Vectorworks 2014