VS:IFC GetEntityProp: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Gets the value and type of a selected property from the IFC entity</desc>
Gets the value and type of a selected property from the IFC entity.</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 24: Line 24:
hObject
hObject
HANDLE
HANDLE
 
Handle to object
</line>
</line>
<line>
<line>
inStrPropName
inStrPropName
STRING
STRING
 
Name of the property
</line>
</line>
<line>
<line>
outStrPropValue
outStrPropValue
STRING
STRING
 
Value of the property
</line>
</line>
<line>
<line>
outTypeSelect
outTypeSelect
INTEGER
INTEGER
 
Type of the property
</line>
</line>
</lineList>
</lineList>
Line 45: Line 45:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark></remark>
<remark>
===== Return Values =====
TRUE on success, FALSE indicates failure – incorrect handle, the object has no IFC data, incorrect name of the property.
 
outTypeSelect – value depends on the property type: 1 – identifier, 2 – double, 3 – boolean, 4 – integer, 5 – number (same as double), 6 – logical, 7 – string, 8 – enu-meration, 9 – select value
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample></sample>
<sample>
==== VectorScript ====
<code lang="pas">
PROCEDURE Test;
VAR
strPropValue: STRING;
hExtrude : HANDLE;
iType : INTEGER;
ok : BOOLEAN;
BEGIN
hExtrude:= FSActLayer;
ok := IFC_GetEntityProp(hExtrude, 'PredefinedType', strPropValue, iType);
AlrtDialog(Concat(strPropValue, ' ,  ',  iType));
END;
 
RUN(Test);
</code>
==== Python ====
<code lang="py">
hExtrude = vs.FSActLayer()
ok, strPropValue, iType = vs.IFC_GetEntityProp(hExtrude, 'PredefinedType')
vs.AlrtDialog(strPropValue + ' ,  ' + str(iType));
</code>
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 09:43, 27 October 2014

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the value and type of a selected property from the IFC entity.

FUNCTION IFC_GetEntityProp(
hObject :HANDLE;
inStrPropName :STRING;
VAR outStrPropValue :STRING;
VAR outTypeSelect :INTEGER) : BOOLEAN;
def vs.IFC_GetEntityProp(hObject, inStrPropName):
    return (BOOLEAN, outStrPropValue, outTypeSelect)

Parameters

hObject HANDLE Handle to object
inStrPropName STRING Name of the property
outStrPropValue STRING Value of the property
outTypeSelect INTEGER Type of the property

Remarks

Return Values

TRUE on success, FALSE indicates failure – incorrect handle, the object has no IFC data, incorrect name of the property.

outTypeSelect – value depends on the property type: 1 – identifier, 2 – double, 3 – boolean, 4 – integer, 5 – number (same as double), 6 – logical, 7 – string, 8 – enu-meration, 9 – select value

Example

VectorScript

PROCEDURE Test;
VAR
	strPropValue: STRING;
	hExtrude : HANDLE;
	iType : INTEGER;
	ok : BOOLEAN;
BEGIN
	hExtrude:= FSActLayer;
	ok := IFC_GetEntityProp(hExtrude, 'PredefinedType', strPropValue, iType);
	AlrtDialog(Concat(strPropValue, ' ,  ',  iType));
END;

RUN(Test);

Python

hExtrude = vs.FSActLayer()
ok, strPropValue, iType = vs.IFC_GetEntityProp(hExtrude, 'PredefinedType')
vs.AlrtDialog(strPropValue + ' ,  ' + str(iType));

Version

Availability: from Vectorworks 2014