VS:IFC GetEntityProp: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
(No difference)

Revision as of 14:34, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

This function gets a value of the selected property of the IFC entity.

FUNCTION IFC_GetEntityProp(
hObject  : HANDLE;
inStrPropName  : STRING;
VAR outStrPropValue  : STRING;
VAR outTypeSelect  : INTEGER) : BOOLEAN;
def vs.IFC_GetEntityProp(hObject, inStrPropName):
    return (BOOLEAN, outStrPropValue, outTypeSelect)

Parameters

hObject HANDLE
inStrPropName STRING
outStrPropValue STRING
outTypeSelect INTEGER

Return Value

TRUE on success, FALSE indicates failure – incorrect handle, the object has no IFC data, incorrect name of the property;

Remarks

outTypeSelect – value depends on the property type:

  • 1 – identifier,
  • 2 – double,
  • 3 – boolean,
  • 4 – integer,
  • 5 – number (same as double),
  • 6 – logical,
  • 7 – string,
  • 8 – enu-meration,
  • 9 – select value;

Example

IFC_GetEntityProp(hExtrude, 'PredefinedType', strPropValue, iType);

Version

Availability: 2010