VS:IFC GetEntityColor

From Vectorworks Developer
Revision as of 08:57, 17 December 2018 by Sasha (talk | contribs)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the default color for an IFC entity type

FUNCTION IFC_GetEntityColor(
inStrIfcType :STRING;
VAR outRed :INTEGER;
VAR outGreen :INTEGER;
VAR outBlue :INTEGER;
VAR outTransp :INTEGER) : BOOLEAN;
def vs.IFC_GetEntityColor(inStrIfcType):
    return (BOOLEAN, outRed, outGreen, outBlue, outTransp)

Parameters

inStrIfcType STRING
outRed INTEGER
outGreen INTEGER
outBlue INTEGER
outTransp INTEGER

Version

Availability: from Vectorworks 2014