VS:IFC GetEntityColor

From Vectorworks Developer
Revision as of 17:36, 18 September 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the default color for an IFC entity type

FUNCTION IFC_GetEntityColor(
inStrIfcType :STRING;
VAR outRed :INTEGER;
VAR outGreen :INTEGER;
VAR outBlue :INTEGER;
VAR outTransp :INTEGER) : BOOLEAN;
def vs.IFC_GetEntityColor(inStrIfcType):
    return (BOOLEAN, outRed, outGreen, outBlue, outTransp)

Parameters

inStrIfcType STRING
outRed INTEGER
outGreen INTEGER
outBlue INTEGER
outTransp INTEGER

Version

Availability: from Vectorworks 2014