VS:IFC GetEntityColor: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 24: Line 24:
inStrIfcType
inStrIfcType
STRING
STRING
IFC Entity type.


</line>
</line>
Line 29: Line 30:
outRed
outRed
INTEGER
INTEGER
Out parameter. Red Value of RGB color model.


</line>
</line>
Line 34: Line 36:
outGreen
outGreen
INTEGER
INTEGER
Out parameter. Green Value of RGB color model.


</line>
</line>
Line 39: Line 42:
outBlue
outBlue
INTEGER
INTEGER
Out parameter. Blue Value of RGB color model.


</line>
</line>
Line 44: Line 48:
outTransp
outTransp
INTEGER
INTEGER
Out parameter. Transepransy value.


</line>
</line>
Line 50: Line 55:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return></return>
<return>
TRUE on success, FALSE indicates failure.
</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark></remark>
<sample>
==== VectorScript ====
<code lang="pas">
PROCEDURE Test;
VAR
red  : INTEGER;
        green : INTEGER;
        blue  : INTEGER;
        transp: INTEGER;
ok    : BOOLEAN;
begin
ok := IFC_GetEntityColor('IfcWall', red, green, blue, transp);
end;


-----------------------------------------------------------------------------------------------------------
Run(Test);
<sample></sample>
</code>
==== Python ====
<code lang="py">
ok = vs.IFC_GetEntityColor('IfcWall', red, green, blue, transp)
</code>
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 08:45, 28 January 2019

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the default color for an IFC entity type

FUNCTION IFC_GetEntityColor(
inStrIfcType :STRING;
VAR outRed :INTEGER;
VAR outGreen :INTEGER;
VAR outBlue :INTEGER;
VAR outTransp :INTEGER) : BOOLEAN;
def vs.IFC_GetEntityColor(inStrIfcType):
    return (BOOLEAN, outRed, outGreen, outBlue, outTransp)

Parameters

inStrIfcType STRING IFC Entity type.
outRed INTEGER Out parameter. Red Value of RGB color model.
outGreen INTEGER Out parameter. Green Value of RGB color model.
outBlue INTEGER Out parameter. Blue Value of RGB color model.
outTransp INTEGER Out parameter. Transepransy value.

Return Value

TRUE on success, FALSE indicates failure.

Example

VectorScript

PROCEDURE Test;
VAR
	red   : INTEGER;
        green : INTEGER;
        blue  : INTEGER;
        transp: INTEGER;
	ok    : BOOLEAN;
begin
	ok := IFC_GetEntityColor('IfcWall', red, green, blue, transp);
end;

Run(Test);

Python

ok = vs.IFC_GetEntityColor('IfcWall', red, green, blue, transp)

Version

Availability: from Vectorworks 2014