VS:IFC GetEntityColor: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
Line 48: Line 48:
</lineList>
</lineList>
</params>
</params>
-----------------------------------------------------------------------------------------------------------
<return></return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 08:57, 17 December 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the default color for an IFC entity type

FUNCTION IFC_GetEntityColor(
inStrIfcType :STRING;
VAR outRed :INTEGER;
VAR outGreen :INTEGER;
VAR outBlue :INTEGER;
VAR outTransp :INTEGER) : BOOLEAN;
def vs.IFC_GetEntityColor(inStrIfcType):
    return (BOOLEAN, outRed, outGreen, outBlue, outTransp)

Parameters

inStrIfcType STRING
outRed INTEGER
outGreen INTEGER
outBlue INTEGER
outTransp INTEGER

Version

Availability: from Vectorworks 2014