VS:IFC DeleteIFCInfo

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Deletes all IFC data attached to the object.

PROCEDURE IFC_DeleteIFCInfo(
hObject :HANDLE, true);
def vs.IFC_DeleteIFCInfo(hObject:HANDLE, true);
    return None

Parameters

hObject HANDLE Handle to the object.
bDoUndo BOOLEAN Use undo or not.

Example

VectorScript

PROCEDURE DeleteIFCInfo;
VAR
        bUndo          : BOOLEAN
        bOK            : BOOLEAN
        hObject        : HANDLE
BEGIN
        {We suggest that we have a handle to an object that has IFC data attached and we want to remove it and have the option to UNDO the change}
        bUndo          := TRUE;
	bOK            := IFC_DeleteIFCInfo( hObject, bUndo );
END;

RUN(DeleteIFCInfo);

Python

# We suggest that we have a handle to an object that has IFC data attached and we want to remove it and have the option to UNDO the change
ok = vs.IFC_DeleteIFCInfo( hObject, True );

Version

Availability: from Vectorworks 2017