VS:IFC DeleteIFCInfo: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (fix typo)
m (fixed Python capital)
 
Line 62: Line 62:
<code lang="py">
<code lang="py">
# We suggest that we have a handle to an object that has IFC data attached and we want to remove it and have the option to UNDO the change
# We suggest that we have a handle to an object that has IFC data attached and we want to remove it and have the option to UNDO the change
ok = vs.IFC_DeleteIFCInfo( hObject, true );
ok = vs.IFC_DeleteIFCInfo( hObject, True );
</code>
</code>
</sample>
</sample>

Latest revision as of 19:09, 20 January 2021

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Deletes all IFC data attached to the object.

PROCEDURE IFC_DeleteIFCInfo(
hObject :HANDLE, true);
def vs.IFC_DeleteIFCInfo(hObject:HANDLE, true);
    return None

Parameters

hObject HANDLE Handle to the object.
bDoUndo BOOLEAN Use undo or not.

Example

VectorScript

PROCEDURE DeleteIFCInfo;
VAR
        bUndo          : BOOLEAN
        bOK            : BOOLEAN
        hObject        : HANDLE
BEGIN
        {We suggest that we have a handle to an object that has IFC data attached and we want to remove it and have the option to UNDO the change}
        bUndo          := TRUE;
	bOK            := IFC_DeleteIFCInfo( hObject, bUndo );
END;

RUN(DeleteIFCInfo);

Python

# We suggest that we have a handle to an object that has IFC data attached and we want to remove it and have the option to UNDO the change
ok = vs.IFC_DeleteIFCInfo( hObject, True );

Version

Availability: from Vectorworks 2017