VS:IFC DefPsetImport

From Vectorworks Developer
Revision as of 07:04, 11 June 2020 by CBM-c- (talk | contribs) (fix typo)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Imports Custom Object Presets from XML or text file.

FUNCTION IFC_DefPsetImport(
strFilePath :STRING) : BOOLEAN;
def vs.IFC_DefPsetImport(strFilePath):
    return BOOLEAN

Parameters

strFilePath STRING The path to the file.

Example

PROCEDURE PsetImport;
VAR
        bOK : BOOLEAN
BEGIN
        {We suggest that we are importing from an Presets.xml file that is located on D:\Vectorworks\Presets.xml}
	bOK := IFC_DefPsetImport( 'D:\Vectorworks\Presets.xml');
END;

RUN(PsetImport);

Python

# We suggest that we are importing from an Presets.xml file that is located on D:\Vectorworks\Presets.xml
ok = vs.IFC_DefPsetImport( 'D:\Vectorworks\Presets.xml');

Version

Availability: from Vectorworks 2016

See Also

IFC_DefPsetBegin

IFC_DefPsetEnd

IFC_DefPsetAddMember

[[VS:IFC_DefPsetBegin|IFC_DefPsetBegin]]

[[VS:IFC_DefPsetEnd|IFC_DefPsetEnd]]

[[VS:IFC_DefPsetAddMember|IFC_DefPsetAddMember]]