VS:IFC DefPsetImport: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 25: Line 25:
strFilePath
strFilePath
STRING
STRING
 
The path to the file.
</line>
</line>
</lineList>
</lineList>
Line 34: Line 34:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample></sample>
<sample>
<code lang="pas">
PROCEDURE PsetImport;
VAR
        bOK : BOOLEAN
BEGIN
        {We suggest that we are importing from an Presets.xml file that is located on D:\Vectorwroks\Presets.xml}
bOK := IFC_DefPsetImport( 'D:\Vectorwroks\Presets.xml');
END;
 
RUN(PsetImport);
</code>
 
==== Python ====
<code lang="py">
# We suggest that we are importing from an Presets.xml file that is located on D:\Vectorwroks\Presets.xml
ok = vs.IFC_DefPsetImport( 'D:\Vectorwroks\Presets.xml');
</code>
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 10:30, 20 November 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Imports Custom Object Presets from XML or text file.

FUNCTION IFC_DefPsetImport(
strFilePath :STRING) : BOOLEAN;
def vs.IFC_DefPsetImport(strFilePath):
    return BOOLEAN

Parameters

strFilePath STRING The path to the file.

Example

PROCEDURE PsetImport;
VAR
        bOK : BOOLEAN
BEGIN
        {We suggest that we are importing from an Presets.xml file that is located on D:\Vectorwroks\Presets.xml}
	bOK := IFC_DefPsetImport( 'D:\Vectorwroks\Presets.xml');
END;

RUN(PsetImport);

Python

# We suggest that we are importing from an Presets.xml file that is located on D:\Vectorwroks\Presets.xml
ok = vs.IFC_DefPsetImport( 'D:\Vectorwroks\Presets.xml');

Version

Availability: from Vectorworks 2016

See Also

IFC_DefPsetBegin

IFC_DefPsetEnd

IFC_DefPsetAddMember

[[VS:IFC_DefPsetBegin|IFC_DefPsetBegin]]

[[VS:IFC_DefPsetEnd|IFC_DefPsetEnd]]

[[VS:IFC_DefPsetAddMember|IFC_DefPsetAddMember]]