VS:IFC DefPsetImport: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
m (fix typo)
 
Line 43: Line 43:
         bOK : BOOLEAN
         bOK : BOOLEAN
BEGIN
BEGIN
         {We suggest that we are importing from an Presets.xml file that is located on D:\Vectorwroks\Presets.xml}
         {We suggest that we are importing from an Presets.xml file that is located on D:\Vectorworks\Presets.xml}
bOK := IFC_DefPsetImport( 'D:\Vectorwroks\Presets.xml');
bOK := IFC_DefPsetImport( 'D:\Vectorworks\Presets.xml');
END;
END;


Line 52: Line 52:
==== Python ====
==== Python ====
<code lang="py">
<code lang="py">
# We suggest that we are importing from an Presets.xml file that is located on D:\Vectorwroks\Presets.xml
# We suggest that we are importing from an Presets.xml file that is located on D:\Vectorworks\Presets.xml
ok = vs.IFC_DefPsetImport( 'D:\Vectorwroks\Presets.xml');
ok = vs.IFC_DefPsetImport( 'D:\Vectorworks\Presets.xml');
</code>
</code>
</sample>
</sample>

Latest revision as of 07:04, 11 June 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Imports Custom Object Presets from XML or text file.

FUNCTION IFC_DefPsetImport(
strFilePath :STRING) : BOOLEAN;
def vs.IFC_DefPsetImport(strFilePath):
    return BOOLEAN

Parameters

strFilePath STRING The path to the file.

Example

PROCEDURE PsetImport;
VAR
        bOK : BOOLEAN
BEGIN
        {We suggest that we are importing from an Presets.xml file that is located on D:\Vectorworks\Presets.xml}
	bOK := IFC_DefPsetImport( 'D:\Vectorworks\Presets.xml');
END;

RUN(PsetImport);

Python

# We suggest that we are importing from an Presets.xml file that is located on D:\Vectorworks\Presets.xml
ok = vs.IFC_DefPsetImport( 'D:\Vectorworks\Presets.xml');

Version

Availability: from Vectorworks 2016

See Also

IFC_DefPsetBegin

IFC_DefPsetEnd

IFC_DefPsetAddMember

[[VS:IFC_DefPsetBegin|IFC_DefPsetBegin]]

[[VS:IFC_DefPsetEnd|IFC_DefPsetEnd]]

[[VS:IFC_DefPsetAddMember|IFC_DefPsetAddMember]]