VS:IFC DefPsetImport: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
No edit summary
(3 intermediate revisions by 3 users not shown)
Line 25: Line 25:
strFilePath
strFilePath
STRING
STRING
 
The path to the file.
</line>
</line>
</lineList>
</lineList>
</params>
</params>
-----------------------------------------------------------------------------------------------------------
<return></return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 34: Line 37:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample></sample>
<sample>
<code lang="pas">
PROCEDURE PsetImport;
VAR
        bOK : BOOLEAN
BEGIN
        {We suggest that we are importing from an Presets.xml file that is located on D:\Vectorwroks\Presets.xml}
bOK := IFC_DefPsetImport( 'D:\Vectorwroks\Presets.xml');
END;
 
RUN(PsetImport);
</code>
 
==== Python ====
<code lang="py">
# We suggest that we are importing from an Presets.xml file that is located on D:\Vectorwroks\Presets.xml
ok = vs.IFC_DefPsetImport( 'D:\Vectorwroks\Presets.xml');
</code>
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso></seeAlso>
<seeAlso>
[[VS:IFC_DefPsetBegin|IFC_DefPsetBegin]]
[[VS:IFC_DefPsetEnd|IFC_DefPsetEnd]]
 
[[VS:IFC_DefPsetAddMember|IFC_DefPsetAddMember]]
</seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 08:57, 17 December 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Imports Custom Object Presets from XML or text file.

FUNCTION IFC_DefPsetImport(
strFilePath :STRING) : BOOLEAN;
def vs.IFC_DefPsetImport(strFilePath):
    return BOOLEAN

Parameters

strFilePath STRING The path to the file.

Example

PROCEDURE PsetImport;
VAR
        bOK : BOOLEAN
BEGIN
        {We suggest that we are importing from an Presets.xml file that is located on D:\Vectorwroks\Presets.xml}
	bOK := IFC_DefPsetImport( 'D:\Vectorwroks\Presets.xml');
END;

RUN(PsetImport);

Python

# We suggest that we are importing from an Presets.xml file that is located on D:\Vectorwroks\Presets.xml
ok = vs.IFC_DefPsetImport( 'D:\Vectorwroks\Presets.xml');

Version

Availability: from Vectorworks 2016

See Also

IFC_DefPsetBegin

IFC_DefPsetEnd

IFC_DefPsetAddMember

[[VS:IFC_DefPsetBegin|IFC_DefPsetBegin]]

[[VS:IFC_DefPsetEnd|IFC_DefPsetEnd]]

[[VS:IFC_DefPsetAddMember|IFC_DefPsetAddMember]]