VS:IFC DefPsetAddMember: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 25: Line 25:
psetName
psetName
STRING
STRING
 
The Custom Property Set Name.
</line>
</line>
<line>
<line>
propName
propName
STRING
STRING
 
Member Name.
</line>
</line>
<line>
<line>
propType
propType
STRING
STRING
 
Member type.
</line>
</line>
</lineList>
</lineList>
Line 41: Line 41:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark></remark>
<remark>
The possible values for the member type are 'IfcReal', 'IfcInteger', 'IfcText', 'IfcBoolean'.
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample></sample>
<sample>
==== VectorScript ====
<code lang="pas">
PROCEDURE PsetAddMember;
VAR
        bOK : BOOLEAN
BEGIN
        {We suggest that 'Chair Details' is a Custom Pset and we want to add 'Height' member with type 'IfcReal'}
bOK := IFC_DefPsetAddMember( 'Chair Details', 'Height', 'IfcReal');
END;
 
RUN(PsetAddMember);
</code>
 
==== Python ====
<code lang="py">
# We suggest that 'Chair Details' is a Custom Pset and we want to add 'Height' member with type 'IfcReal'
ok = vs.IFC_DefPsetAddMember( 'Chair Details', 'Height', 'IfcReal');
</code>
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 56: Line 77:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from Vectorworks 2016
Availability: from Vectorworks 2016.


</version>
</version>

Revision as of 10:23, 20 November 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Adds a new member to the currently defined Custom Object Preset.

FUNCTION IFC_DefPsetAddMember(
psetName :STRING;
propName :STRING;
propType :STRING) : BOOLEAN;
def vs.IFC_DefPsetAddMember(psetName, propName, propType):
    return BOOLEAN

Parameters

psetName STRING The Custom Property Set Name.
propName STRING Member Name.
propType STRING Member type.

Remarks

The possible values for the member type are 'IfcReal', 'IfcInteger', 'IfcText', 'IfcBoolean'.

Example

VectorScript

PROCEDURE PsetAddMember;
VAR
        bOK : BOOLEAN
BEGIN
        {We suggest that 'Chair Details' is a Custom Pset and we want to add 'Height' member with type 'IfcReal'}
	bOK := IFC_DefPsetAddMember( 'Chair Details', 'Height', 'IfcReal');
END;

RUN(PsetAddMember);

Python

# We suggest that 'Chair Details' is a Custom Pset and we want to add 'Height' member with type 'IfcReal'
ok = vs.IFC_DefPsetAddMember( 'Chair Details', 'Height', 'IfcReal');

Version

Availability: from Vectorworks 2016.

See Also

IFC_DefPsetBegin

IFC_DefPsetEnd

IFC_DefPsetImport

[[VS:IFC_DefPsetBegin|IFC_DefPsetBegin]]

[[VS:IFC_DefPsetEnd|IFC_DefPsetEnd]]

[[VS:IFC_DefPsetImport|IFC_DefPsetImport]]