VS:IFC DefPsetAddMember: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 39: Line 39:
</lineList>
</lineList>
</params>
</params>
-----------------------------------------------------------------------------------------------------------
<return>
TRUE on success. FALSE on failure.
</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 08:51, 17 December 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Adds a new member to the currently defined Custom Object Preset.

FUNCTION IFC_DefPsetAddMember(
psetName :STRING;
propName :STRING;
propType :STRING) : BOOLEAN;
def vs.IFC_DefPsetAddMember(psetName, propName, propType):
    return BOOLEAN

Parameters

psetName STRING The Custom Property Set Name.
propName STRING Member Name.
propType STRING Member type.

Return Value

TRUE on success. FALSE on failure.

Remarks

The possible values for the member type are 'IfcReal', 'IfcInteger', 'IfcText', 'IfcBoolean'.

Example

VectorScript

PROCEDURE PsetAddMember;
VAR
        bOK : BOOLEAN
BEGIN
        {We suggest that 'Chair Details' is a Custom Pset and we want to add 'Height' member with type 'IfcReal'}
	bOK := IFC_DefPsetAddMember( 'Chair Details', 'Height', 'IfcReal');
END;

RUN(PsetAddMember);

Python

# We suggest that 'Chair Details' is a Custom Pset and we want to add 'Height' member with type 'IfcReal'
ok = vs.IFC_DefPsetAddMember( 'Chair Details', 'Height', 'IfcReal');

Version

Availability: from Vectorworks 2016.

See Also

IFC_DefPsetBegin

IFC_DefPsetEnd

IFC_DefPsetImport

[[VS:IFC_DefPsetBegin|IFC_DefPsetBegin]]

[[VS:IFC_DefPsetEnd|IFC_DefPsetEnd]]

[[VS:IFC_DefPsetImport|IFC_DefPsetImport]]