VS:IFC DMSaveSettings

From Vectorworks Developer
Revision as of 09:23, 22 November 2018 by NBeshevliev (talk | contribs)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Saves current IFC Data Mapping. If bFileSettings is set to FALSE, setting will be saved only for indicated Object.

FUNCTION IFC_DMSaveSettings(
inStrParam :STRING;
inObjName :STRING;
bFileSettings :BOOLEAN) : BOOLEAN;
def vs.IFC_DMSaveSettings(inStrParam, inObjName, bFileSettings):
    return BOOLEAN

Parameters

inStrParam STRING The name which the IFC Data Mapping will be saved with.
inObjName STRING Object name.
bFileSettings BOOLEAN TRUE if the user wants to save the whole IFC Data Mapping. FALSE - saves only the specified Object's mapping.

Remarks

Return Values

TRUE on success, FALSE indicates failure.

Example

VectorScript

PROCEDURE Test;
VAR
	ok : BOOLEAN;
BEGIN
	ok := IFC_DMSaveSettings('MyIFCMapping', '', TRUE);
END;

RUN(Test);

Python

ok = vs.IFC_DMSaveSettings('MyIFCMapping', '', TRUE)

Version

Available from: Vectorworks 2017