VS:IFC DMSaveSettings: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with "{{LocationMain|category=LocationVS|specific=}} __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <de...")
 
No edit summary
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Saves current IFC Data Mapping. If bFileSettings is set to FALSE, setting will be saved only for indicated Object.
</desc>
</desc>


Line 24: Line 25:
inStrParam
inStrParam
STRING
STRING
The name which the IFC Data Mapping will be saved with.


</line>
</line>
Line 29: Line 31:
inObjName
inObjName
STRING
STRING
Object name.


</line>
</line>
Line 34: Line 37:
bFileSettings
bFileSettings
BOOLEAN
BOOLEAN
TRUE if the user wants to save the whole IFC Data Mapping. FALSE - saves only the specified Object's mapping.


</line>
</line>
Line 40: Line 44:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark></remark>
<remark>
===== Return Values =====
TRUE on success, FALSE indicates failure.
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample></sample>
<sample>
==== VectorScript ====
<code lang="pas">
PROCEDURE Test;
VAR
ok : BOOLEAN;
BEGIN
ok := IFC_DMSaveSettings('MyIFCMapping', '', TRUE);
END;
 
RUN(Test);
</code>
==== Python ====
<code lang="py">
ok = vs.IFC_DMSaveSettings('MyIFCMapping', '', TRUE)
</code>
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 09:23, 22 November 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Saves current IFC Data Mapping. If bFileSettings is set to FALSE, setting will be saved only for indicated Object.

FUNCTION IFC_DMSaveSettings(
inStrParam :STRING;
inObjName :STRING;
bFileSettings :BOOLEAN) : BOOLEAN;
def vs.IFC_DMSaveSettings(inStrParam, inObjName, bFileSettings):
    return BOOLEAN

Parameters

inStrParam STRING The name which the IFC Data Mapping will be saved with.
inObjName STRING Object name.
bFileSettings BOOLEAN TRUE if the user wants to save the whole IFC Data Mapping. FALSE - saves only the specified Object's mapping.

Remarks

Return Values

TRUE on success, FALSE indicates failure.

Example

VectorScript

PROCEDURE Test;
VAR
	ok : BOOLEAN;
BEGIN
	ok := IFC_DMSaveSettings('MyIFCMapping', '', TRUE);
END;

RUN(Test);

Python

ok = vs.IFC_DMSaveSettings('MyIFCMapping', '', TRUE)

Version

Available from: Vectorworks 2017