VS:IFC DMSaveSettings: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 44: Line 44:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<return>TRUE on success, FALSE indicates failure.</return>
===== Return Values =====
 
TRUE on success, FALSE indicates failure.
-----------------------------------------------------------------------------------------------------------
</remark>
<remark></remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 08:53, 17 December 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Saves current IFC Data Mapping. If bFileSettings is set to FALSE, setting will be saved only for indicated Object.

FUNCTION IFC_DMSaveSettings(
inStrParam :STRING;
inObjName :STRING;
bFileSettings :BOOLEAN) : BOOLEAN;
def vs.IFC_DMSaveSettings(inStrParam, inObjName, bFileSettings):
    return BOOLEAN

Parameters

inStrParam STRING The name which the IFC Data Mapping will be saved with.
inObjName STRING Object name.
bFileSettings BOOLEAN TRUE if the user wants to save the whole IFC Data Mapping. FALSE - saves only the specified Object's mapping.

Return Value

TRUE on success, FALSE indicates failure.

Example

VectorScript

PROCEDURE Test;
VAR
	ok : BOOLEAN;
BEGIN
	ok := IFC_DMSaveSettings('MyIFCMapping', '', TRUE);
END;

RUN(Test);

Python

ok = vs.IFC_DMSaveSettings('MyIFCMapping', '', TRUE)

Version

Available from: Vectorworks 2017