VS:IFC DMResetToDef: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with "{{LocationMain|category=LocationVS|specific=}} __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <de...")
 
No edit summary
 
(One intermediate revision by the same user not shown)
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Resets the data mapping to the default values.
</desc>
</desc>


Line 17: Line 18:
</funcDef>
</funcDef>
</def>
</def>
-----------------------------------------------------------------------------------------------------------
<return>The function returns a boolean flag if the operation succeeded or not.</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 22: Line 26:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample></sample>
<sample>
==== VectorScript ====
<code lang="pas">
PROCEDURE Test;
VAR
ok : BOOLEAN;
BEGIN
ok := IFC_DMResetToDef();
END;
 
RUN(Test);
</code>
 
==== Python ====
<code lang="py">
ok = vs.IFC_DMResetToDef()
</code>
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 08:53, 17 December 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Resets the data mapping to the default values.

FUNCTION IFC_DMResetToDef : BOOLEAN;
def vs.IFC_DMResetToDef():
    return BOOLEAN

Return Value

The function returns a boolean flag if the operation succeeded or not.

Example

VectorScript

PROCEDURE Test;
VAR
	ok : BOOLEAN;
BEGIN
	ok := IFC_DMResetToDef();
END;

RUN(Test);

Python

ok	= vs.IFC_DMResetToDef()

Version

Available from: Vectorworks 2017