VS:IFC DMResetToDef: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with "{{LocationMain|category=LocationVS|specific=}} __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <de...")
 
No edit summary
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Resets the data mapping to the default values.
</desc>
</desc>


Line 19: Line 20:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark></remark>
<remark>
===== Return Values =====
The function returns a boolean flag if the operation succeeded or not.
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample></sample>
<sample>
==== VectorScript ====
<code lang="pas">
PROCEDURE Test;
VAR
ok : BOOLEAN;
BEGIN
ok := IFC_DMResetToDef();
END;
 
RUN(Test);
</code>
 
==== Python ====
<code lang="py">
ok = vs.IFC_DMResetToDef()
</code>
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 14:14, 1 November 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Resets the data mapping to the default values.

FUNCTION IFC_DMResetToDef : BOOLEAN;
def vs.IFC_DMResetToDef():
    return BOOLEAN

Remarks

Return Values

The function returns a boolean flag if the operation succeeded or not.

Example

VectorScript

PROCEDURE Test;
VAR
	ok : BOOLEAN;
BEGIN
	ok := IFC_DMResetToDef();
END;

RUN(Test);

Python

ok	= vs.IFC_DMResetToDef()

Version

Available from: Vectorworks 2017