VS:IFC DMLoadSettings

From Vectorworks Developer
Revision as of 09:09, 5 November 2018 by NBeshevliev (talk | contribs)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Loads the indicated IFC Data Mapping to Document.

FUNCTION IFC_DMLoadSettings(
inStrParam :STRING) : BOOLEAN;
def vs.IFC_DMLoadSettings(inStrParam):
    return BOOLEAN

Parameters

inStrParam STRING IFC Data Mapping name. If parameter is Empty, it's going to Load the Default IFC Data Mapping.

Remarks

Return Values

TRUE on success, FALSE indicates failure.

Example

VectorScript

PROCEDURE Test;
VAR
	ok : BOOLEAN;
BEGIN
	ok := IFC_DMLoadSettings('MyIFCMapping');
END;

RUN(Test);

Python

ok = vs.IFC_DMLoadSettings('MyIFCMapping')

Version

Available from: Vectorworks 2017