VS:IFC DMLoadSettings: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with "{{LocationMain|category=LocationVS|specific=}} __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <de...")
 
m (fix typo)
 
(2 intermediate revisions by 2 users not shown)
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Loads the indicated IFC Data Mapping to Document.
</desc>
</desc>


Line 24: Line 25:
inStrParam
inStrParam
STRING
STRING
IFC Data Mapping name. If parameter is Empty, it's going to load the Default IFC Data Mapping.


</line>
</line>
</lineList>
</lineList>
</params>
</params>
-----------------------------------------------------------------------------------------------------------
<return>TRUE on success, FALSE indicates failure.</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 33: Line 38:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample></sample>
<sample>
==== VectorScript ====
<code lang="pas">
PROCEDURE Test;
VAR
ok : BOOLEAN;
BEGIN
ok := IFC_DMLoadSettings('MyIFCMapping');
END;
 
RUN(Test);
</code>
==== Python ====
<code lang="py">
ok = vs.IFC_DMLoadSettings('MyIFCMapping')
</code>
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 09:55, 11 June 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Loads the indicated IFC Data Mapping to Document.

FUNCTION IFC_DMLoadSettings(
inStrParam :STRING) : BOOLEAN;
def vs.IFC_DMLoadSettings(inStrParam):
    return BOOLEAN

Parameters

inStrParam STRING IFC Data Mapping name. If parameter is Empty, it's going to load the Default IFC Data Mapping.

Return Value

TRUE on success, FALSE indicates failure.

Example

VectorScript

PROCEDURE Test;
VAR
	ok : BOOLEAN;
BEGIN
	ok := IFC_DMLoadSettings('MyIFCMapping');
END;

RUN(Test);

Python

ok = vs.IFC_DMLoadSettings('MyIFCMapping')

Version

Available from: Vectorworks 2017