VS:IFC DMLoadSettings: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with "{{LocationMain|category=LocationVS|specific=}} __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <de...")
 
No edit summary
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Loads the indicated IFC Data Mapping to Document.
</desc>
</desc>


Line 24: Line 25:
inStrParam
inStrParam
STRING
STRING
IFC Data Mapping name. If parameter is Empty, it's going to Load the Default IFC Data Mapping.


</line>
</line>
Line 30: Line 32:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark></remark>
<remark>
===== Return Values =====
TRUE on success, FALSE indicates failure.
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample></sample>
<sample>
==== VectorScript ====
<code lang="pas">
PROCEDURE Test;
VAR
ok : BOOLEAN;
BEGIN
ok := IFC_DMLoadSettings('MyIFCMapping');
END;
 
RUN(Test);
</code>
==== Python ====
<code lang="py">
ok = vs.IFC_DMLoadSettings('MyIFCMapping')
</code>
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 09:09, 5 November 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Loads the indicated IFC Data Mapping to Document.

FUNCTION IFC_DMLoadSettings(
inStrParam :STRING) : BOOLEAN;
def vs.IFC_DMLoadSettings(inStrParam):
    return BOOLEAN

Parameters

inStrParam STRING IFC Data Mapping name. If parameter is Empty, it's going to Load the Default IFC Data Mapping.

Remarks

Return Values

TRUE on success, FALSE indicates failure.

Example

VectorScript

PROCEDURE Test;
VAR
	ok : BOOLEAN;
BEGIN
	ok := IFC_DMLoadSettings('MyIFCMapping');
END;

RUN(Test);

Python

ok = vs.IFC_DMLoadSettings('MyIFCMapping')

Version

Available from: Vectorworks 2017