VS:IFC DMIsObjEnabled: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 35: Line 35:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample></sample>
<sample>
==== VectorScript ====
<code lang="pas">
PROCEDURE isObjEnabled;
VAR
bOk : BOOLEAN;
BEGIN
bOk  = IFC_DMIsObjEnabled('Space'); {bOk determines if the Space Object is enabled in the current mapping}
END;
 
RUN(GetEntriesCnt);
</code>
 
==== Python ====
<code lang="py">
bOk = vs.IFC_DMIsObjEnabled('Space'); #bOk determines if the Space Object is enabled in the current mapping
</code>
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
[[Category:VS Function Reference|IFC DMEnableObject]]
[[Category:VS Function Reference|IFC_DMIsObjEnabled]]
</seeAlso>
</seeAlso>



Revision as of 11:35, 29 October 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns a flag that shows whether the provided object is enabled in the current mapping settings.

FUNCTION IFC_DMIsObjEnabled(
inStrObjName :STRING) : BOOLEAN;
def vs.IFC_DMIsObjEnabled(inStrObjName):
    return BOOLEAN

Parameters

inStrObjName STRING Object's name.

Example

VectorScript

PROCEDURE isObjEnabled;
VAR
	bOk : BOOLEAN;
BEGIN
	bOk   = IFC_DMIsObjEnabled('Space'); {bOk determines if the Space Object is enabled in the current mapping}
END;

RUN(GetEntriesCnt);

Python

bOk = vs.IFC_DMIsObjEnabled('Space'); #bOk determines if the Space Object is enabled in the current mapping

Version

Available from: Vectorworks 2017

See Also

[[Category:VS Function Reference|IFC_DMIsObjEnabled]]