VS:IFC DMIsObjEnabled: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
(5 intermediate revisions by 2 users not shown)
Line 30: Line 30:
</lineList>
</lineList>
</params>
</params>
-----------------------------------------------------------------------------------------------------------
<return>TRUE on success, FALSE on failure.</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 38: Line 41:
==== VectorScript ====
==== VectorScript ====
<code lang="pas">
<code lang="pas">
PROCEDURE isObjEnabled;
PROCEDURE IsObjEnabled;
VAR
VAR
bOk : BOOLEAN;
bOk : BOOLEAN;
BEGIN
BEGIN
bOk   = IFC_DMIsObjEnabled('Space'); {bOk determines if the Space Object is enabled in the current mapping}
bOk := IFC_DMIsObjEnabled('Space'); {bOk returns if the Space Object is enabled in the current mapping}
END;
END;


RUN(GetEntriesCnt);
RUN(IsObjEnabled);
</code>
</code>


==== Python ====
==== Python ====
<code lang="py">
<code lang="py">
bOk = vs.IFC_DMIsObjEnabled('Space'); #bOk determines if the Space Object is enabled in the current mapping
bOk = vs.IFC_DMIsObjEnabled('Space'); #bOk returns if the Space Object is enabled in the current mapping
</code>
</code>
</sample>
</sample>
Line 56: Line 59:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
[[Category:VS Function Reference|IFC_DMIsObjEnabled]]
[[VS:IFC_DMEnableObject]]
</seeAlso>
</seeAlso>



Latest revision as of 08:54, 17 December 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns a flag that shows whether the provided object is enabled in the current mapping settings.

FUNCTION IFC_DMIsObjEnabled(
inStrObjName :STRING) : BOOLEAN;
def vs.IFC_DMIsObjEnabled(inStrObjName):
    return BOOLEAN

Parameters

inStrObjName STRING Object's name.

Return Value

TRUE on success, FALSE on failure.

Example

VectorScript

PROCEDURE IsObjEnabled;
VAR
	bOk : BOOLEAN;
BEGIN
	bOk := IFC_DMIsObjEnabled('Space'); {bOk returns if the Space Object is enabled in the current mapping}
END;

RUN(IsObjEnabled);

Python

bOk = vs.IFC_DMIsObjEnabled('Space'); #bOk returns if the Space Object is enabled in the current mapping

Version

Available from: Vectorworks 2017

See Also

VS:IFC_DMEnableObject

[[VS:IFC_DMEnableObject]]