VS:IFC DMIsObjEnabled: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with " {{LocationMain|category=LocationVS|specific=}} __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <d...")
 
No edit summary
 
(7 intermediate revisions by 2 users not shown)
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Returns a flag that shows whether the provided object is enabled in the current mapping settings.
</desc>
</desc>


Line 25: Line 26:
inStrObjName
inStrObjName
STRING
STRING
 
Object's name.
</line>
</line>
</lineList>
</lineList>
</params>
</params>
-----------------------------------------------------------------------------------------------------------
<return>TRUE on success, FALSE on failure.</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 34: Line 38:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample></sample>
<sample>
==== VectorScript ====
<code lang="pas">
PROCEDURE IsObjEnabled;
VAR
bOk : BOOLEAN;
BEGIN
bOk := IFC_DMIsObjEnabled('Space'); {bOk returns if the Space Object is enabled in the current mapping}
END;
 
RUN(IsObjEnabled);
</code>
 
==== Python ====
<code lang="py">
bOk = vs.IFC_DMIsObjEnabled('Space'); #bOk returns if the Space Object is enabled in the current mapping
</code>
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso></seeAlso>
<seeAlso>
[[VS:IFC_DMEnableObject]]
</seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 08:54, 17 December 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns a flag that shows whether the provided object is enabled in the current mapping settings.

FUNCTION IFC_DMIsObjEnabled(
inStrObjName :STRING) : BOOLEAN;
def vs.IFC_DMIsObjEnabled(inStrObjName):
    return BOOLEAN

Parameters

inStrObjName STRING Object's name.

Return Value

TRUE on success, FALSE on failure.

Example

VectorScript

PROCEDURE IsObjEnabled;
VAR
	bOk : BOOLEAN;
BEGIN
	bOk := IFC_DMIsObjEnabled('Space'); {bOk returns if the Space Object is enabled in the current mapping}
END;

RUN(IsObjEnabled);

Python

bOk = vs.IFC_DMIsObjEnabled('Space'); #bOk returns if the Space Object is enabled in the current mapping

Version

Available from: Vectorworks 2017

See Also

VS:IFC_DMEnableObject

[[VS:IFC_DMEnableObject]]