VS:IFC DMIsObjEnabled: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 42: Line 42:
bOk : BOOLEAN;
bOk : BOOLEAN;
BEGIN
BEGIN
bOk   = IFC_DMIsObjEnabled('Space'); {bOk determines if the Space Object is enabled in the current mapping}
bOk := IFC_DMIsObjEnabled('Space'); {bOk determines if the Space Object is enabled in the current mapping}
END;
END;



Revision as of 10:08, 20 November 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns a flag that shows whether the provided object is enabled in the current mapping settings.

FUNCTION IFC_DMIsObjEnabled(
inStrObjName :STRING) : BOOLEAN;
def vs.IFC_DMIsObjEnabled(inStrObjName):
    return BOOLEAN

Parameters

inStrObjName STRING Object's name.

Example

VectorScript

PROCEDURE IsObjEnabled;
VAR
	bOk : BOOLEAN;
BEGIN
	bOk := IFC_DMIsObjEnabled('Space'); {bOk determines if the Space Object is enabled in the current mapping}
END;

RUN(IsObjEnabled);

Python

bOk = vs.IFC_DMIsObjEnabled('Space'); #bOk determines if the Space Object is enabled in the current mapping

Version

Available from: Vectorworks 2017

See Also

VS:IFC_DMEnableObject

[[VS:IFC_DMEnableObject]]