VS:IFC DMGetPSetName

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the Name for Mapped IfcEntity's Property Set IFC Data Mapping.

FUNCTION IFC_DMGetPSetName(
strObjectName :STRING;
strEntryName :STRING;
psetIndex :INTEGER;
VAR outStrPSetName :STRING) : BOOLEAN;
def vs.IFC_DMGetPSetName(strObjectName, strEntryName, psetIndex):
    return (BOOLEAN, outStrPSetName)

Parameters

strObjectName STRING
strEntryName STRING
psetIndex INTEGER
outStrPSetName STRING

Version

Availability: from Vectorworks 2021