VS:IFC DMGetFieldType

From Vectorworks Developer
Revision as of 08:56, 17 December 2018 by Sasha (talk | contribs)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets indicated field type from current IFC Data Mapping.

FUNCTION IFC_DMGetFieldType(
inStrObjName :STRING;
inStrEntryName :STRING;
inStrFieldName :STRING;
VAR outType :INTEGER) : BOOLEAN;
def vs.IFC_DMGetFieldType(inStrObjName, inStrEntryName, inStrFieldName):
    return (BOOLEAN, outType)

Parameters

inStrObjName STRING
inStrEntryName STRING
inStrFieldName STRING
outType INTEGER

Version

Available from: Vectorworks 2017