VS:IFC DMGetFieldName

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets indicated field name from current IFC Data Mapping.

FUNCTION IFC_DMGetFieldName(
inStrObjName :STRING;
inStrEntryName :STRING;
index :INTEGER;
VAR outStrFieldName :STRING) : BOOLEAN;
def vs.IFC_DMGetFieldName(inStrObjName, inStrEntryName, index):
    return (BOOLEAN, outStrFieldName)

Parameters

inStrObjName STRING
inStrEntryName STRING
index INTEGER
outStrFieldName STRING

Version

Available from: Vectorworks 2017