VS:IFC DMGetEntriesCnt

From Vectorworks Developer
Revision as of 08:51, 17 December 2018 by Sasha (talk | contribs)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the count of entries for indicated object from current IFC Data Mapping.

FUNCTION IFC_DMGetEntriesCnt(
inStrObjName :STRING;
VAR outCount :INTEGER) : BOOLEAN;
def vs.IFC_DMGetEntriesCnt(inStrObjName):
    return (BOOLEAN, outCount)

Parameters

inStrObjName STRING Object name.
outCount INTEGER Returns IfcEntity groups count from IFC Data Mapping.

Example

VectorScript

PROCEDURE GetEntriesCnt;
VAR
	count 	: INTEGER;
BEGIN
	IFC_DMGetEntriesCnt('Space', count);
END;

RUN(GetEntriesCnt);

Python

count = 0;
vs.IFC_DMGetEntriesCnt('Space', count);

Version

Available from: Vectorworks 2017