VS:IFC DMGetEntriesCnt: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 40: Line 40:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample></sample>
<sample>
==== VectorScript ====
<code lang="pas">
PROCEDURE GetEntriesCnt;
VAR
count : INTEGER;
BEGIN
IFC_DMGetEntriesCnt('Space', count);
END;
 
RUN(GetEntriesCnt);
</code>
 
==== Python ====
<code lang="py">
count = 0;
vs.IFC_DMGetEntriesCnt('Space', count);
</code>
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 08:29, 26 October 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the count of entries for indicated object from current IFC Data Mapping.

FUNCTION IFC_DMGetEntriesCnt(
inStrObjName :STRING;
VAR outCount :INTEGER) : BOOLEAN;
def vs.IFC_DMGetEntriesCnt(inStrObjName):
    return (BOOLEAN, outCount)

Parameters

inStrObjName STRING Object name.
outCount INTEGER Returns IfcEntity groups count from IFC Data Mapping.

Example

VectorScript

PROCEDURE GetEntriesCnt;
VAR
	count 	: INTEGER;
BEGIN
	IFC_DMGetEntriesCnt('Space', count);
END;

RUN(GetEntriesCnt);

Python

count = 0;
vs.IFC_DMGetEntriesCnt('Space', count);

Version

Available from: Vectorworks 2017