VS:IFC DMGetEntriesCnt: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with " {{LocationMain|category=LocationVS|specific=}} __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <d...")
 
No edit summary
(2 intermediate revisions by one other user not shown)
Line 26: Line 26:
inStrObjName
inStrObjName
STRING
STRING
 
Object name.
</line>
</line>
<line>
<line>
outCount
outCount
INTEGER
INTEGER
 
Returns IfcEntity groups count from IFC Data Mapping.
</line>
</line>
</lineList>
</lineList>
</params>
</params>
-----------------------------------------------------------------------------------------------------------
<return></return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 40: Line 43:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample></sample>
<sample>
==== VectorScript ====
<code lang="pas">
PROCEDURE GetEntriesCnt;
VAR
count : INTEGER;
BEGIN
IFC_DMGetEntriesCnt('Space', count);
END;
 
RUN(GetEntriesCnt);
</code>
 
==== Python ====
<code lang="py">
count = 0;
vs.IFC_DMGetEntriesCnt('Space', count);
</code>
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 08:51, 17 December 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the count of entries for indicated object from current IFC Data Mapping.

FUNCTION IFC_DMGetEntriesCnt(
inStrObjName :STRING;
VAR outCount :INTEGER) : BOOLEAN;
def vs.IFC_DMGetEntriesCnt(inStrObjName):
    return (BOOLEAN, outCount)

Parameters

inStrObjName STRING Object name.
outCount INTEGER Returns IfcEntity groups count from IFC Data Mapping.

Example

VectorScript

PROCEDURE GetEntriesCnt;
VAR
	count 	: INTEGER;
BEGIN
	IFC_DMGetEntriesCnt('Space', count);
END;

RUN(GetEntriesCnt);

Python

count = 0;
vs.IFC_DMGetEntriesCnt('Space', count);

Version

Available from: Vectorworks 2017