VS:IFC DMDeleteEntry

From Vectorworks Developer
Revision as of 08:49, 17 December 2018 by Sasha (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Deletes an Еntry group from indicated object, from current IFC Data Mapping.

FUNCTION IFC_DMDeleteEntry(
inStrObjName :STRING;
inStrEntryName :STRING) : BOOLEAN;
def vs.IFC_DMDeleteEntry(inStrObjName, inStrEntryName):
    return BOOLEAN

Parameters

inStrObjName STRING Object Name.
inStrEntryName STRING Ifc Entry group name.

Return Value

TRUE on success, FALSE indicates failure.

Example

Assume we want to clear "IfcWall" Entry Group from the mapping for Wall Object:

VectorScript

PROCEDURE Test;
VAR
	ok : BOOLEAN;
BEGIN
	ok := IFC_DMDeleteEntry('Wall', 'IfcWall');
END;

RUN(Test);

Python

ok = vs.IFC_DMDeleteEntry('Wall', 'IfcWall')

Version

Available from: Vectorworks 2017