VS:IFC DMDeleteEntry: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with " {{LocationMain|category=LocationVS|specific=}} __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <d...")
 
No edit summary
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Deletes an entry from indicated object, from current IFC Data Mapping.
Deletes an Еntry group from indicated object, from current IFC Data Mapping.
</desc>
</desc>


Line 26: Line 26:
inStrObjName
inStrObjName
STRING
STRING
Object Name.


</line>
</line>
Line 31: Line 32:
inStrEntryName
inStrEntryName
STRING
STRING
Ifc Entry group name.


</line>
</line>
Line 37: Line 39:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark></remark>
<remark>
===== Return Values =====
TRUE on success, FALSE indicates failure.
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample></sample>
<sample>
Assume we want to clear "IfcWall" Entry Group from the mapping for Wall Object:
 
==== VectorScript ====
<code lang="pas">
PROCEDURE Test;
VAR
ok : BOOLEAN;
BEGIN
ok := IFC_DMDeleteEntry('Wall', 'IfcWall');
END;
 
RUN(Test);
</code>
==== Python ====
<code lang="py">
ok = vs.IFC_DMDeleteEntry('Wall', 'IfcWall')
</code>
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 07:18, 24 October 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Deletes an Еntry group from indicated object, from current IFC Data Mapping.

FUNCTION IFC_DMDeleteEntry(
inStrObjName :STRING;
inStrEntryName :STRING) : BOOLEAN;
def vs.IFC_DMDeleteEntry(inStrObjName, inStrEntryName):
    return BOOLEAN

Parameters

inStrObjName STRING Object Name.
inStrEntryName STRING Ifc Entry group name.

Remarks

Return Values

TRUE on success, FALSE indicates failure.

Example

Assume we want to clear "IfcWall" Entry Group from the mapping for Wall Object:

VectorScript

PROCEDURE Test;
VAR
	ok : BOOLEAN;
BEGIN
	ok := IFC_DMDeleteEntry('Wall', 'IfcWall');
END;

RUN(Test);

Python

ok = vs.IFC_DMDeleteEntry('Wall', 'IfcWall')

Version

Available from: Vectorworks 2017