VS:IFC DMAddPSetFld

From Vectorworks Developer
Revision as of 15:47, 16 September 2020 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Adds Field to specified IfcEntry's PSet.

FUNCTION IFC_DMAddPSetFld(
strObjectName :STRING;
strEntryName :STRING;
strPSetName :STRING;
strFieldName :STRING;
type :INTEGER;
bOptional :BOOLEAN;
bEnable :BOOLEAN;
bEmpty :BOOLEAN) : BOOLEAN;
def vs.IFC_DMAddPSetFld(strObjectName, strEntryName, strPSetName, strFieldName, type, bOptional, bEnable, bEmpty):
    return BOOLEAN

Parameters

strObjectName STRING
strEntryName STRING
strPSetName STRING
strFieldName STRING
type INTEGER
bOptional BOOLEAN
bEnable BOOLEAN
bEmpty BOOLEAN

Version

Availability: from Vectorworks 2021