VS:IFC DMAddField

From Vectorworks Developer
Revision as of 06:47, 4 April 2018 by Sasha (talk | contribs) (Created page with " {{LocationMain|category=LocationVS|specific=}} __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <d...")
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Adds a field to current IFC Data Mapping.

FUNCTION IFC_DMAddField(
inStrObjName :STRING;
inStrEntryName :STRING;
inStrFieldName :STRING;
type :INTEGER;
bOptional :BOOLEAN;
bEnable :BOOLEAN;
bEmpty :BOOLEAN) : BOOLEAN;
def vs.IFC_DMAddField(inStrObjName, inStrEntryName, inStrFieldName, type, bOptional, bEnable, bEmpty):
    return BOOLEAN

Parameters

inStrObjName STRING
inStrEntryName STRING
inStrFieldName STRING
type INTEGER
bOptional BOOLEAN
bEnable BOOLEAN
bEmpty BOOLEAN

Version

Available from: Vectorworks 2017