VS:IFC ClearPset

From Vectorworks Developer
Revision as of 08:47, 17 December 2018 by Sasha (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Removes a Property Set from the object's attached Ifc Record.

FUNCTION IFC_ClearPset(
hObject :HANDLE;
inStrPsetName :STRING) : BOOLEAN;
def vs.IFC_ClearPset(hObject, inStrPsetName):
    return BOOLEAN

Parameters

hObject HANDLE Handle to the object.
inStrPsetName STRING The name of the Property Set.

Return Value

TRUE on success, FALSE indicates failure.

Example

Assume we want to clear a "PSet_WallCommon" from Object which has already attached Ifc Record with that Property Set:

VectorScript

PROCEDURE Test;
VAR
	hObject : HANDLE;
	ok : BOOLEAN;
BEGIN
	hObject := FSActLayer;
	ok := IFC_ClearPset(hObject, 'PSet_WallCommon');
END;

RUN(Test);

Python

hObject = vs.FSActLayer()
ok = vs.IFC_ClearPset(hObject, 'PSet_WallCommon')

Version

Available from: Vectorworks 2016