VS:IFC ClearPset: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with " {{LocationMain|category=LocationVS|specific=}} __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <d...")
 
No edit summary
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Removes a property set from the object.
Removes a Property Set from the object's attached Ifc Record.
</desc>
</desc>


Line 31: Line 31:
inStrPsetName
inStrPsetName
STRING
STRING
The name of the Pset.
The name of the Property Set.
</line>
</line>
</lineList>
</lineList>
Line 37: Line 37:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark></remark>
<remark>
===== Return Values =====
TRUE on success, FALSE indicates failure.
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample></sample>
<sample>
==== VectorScript ====
<code lang="pas">
PROCEDURE Test;
VAR
hObject : HANDLE;
ok : BOOLEAN;
BEGIN
hObject := FSActLayer;
ok := IFC_ClearPset(hObject, 'PSet_WallCommon');
END;
 
RUN(Test);
</code>
==== Python ====
<code lang="py">
hObject = vs.FSActLayer()
ok = vs.IFC_ClearPset(hObject, 'PSet_WallCommon')
</code>
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 12:59, 16 October 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Removes a Property Set from the object's attached Ifc Record.

FUNCTION IFC_ClearPset(
hObject :HANDLE;
inStrPsetName :STRING) : BOOLEAN;
def vs.IFC_ClearPset(hObject, inStrPsetName):
    return BOOLEAN

Parameters

hObject HANDLE Handle to the object.
inStrPsetName STRING The name of the Property Set.

Remarks

Return Values

TRUE on success, FALSE indicates failure.

Example

VectorScript

PROCEDURE Test;
VAR
	hObject : HANDLE;
	ok : BOOLEAN;
BEGIN
	hObject := FSActLayer;
	ok := IFC_ClearPset(hObject, 'PSet_WallCommon');
END;

RUN(Test);

Python

hObject = vs.FSActLayer()
ok = vs.IFC_ClearPset(hObject, 'PSet_WallCommon')

Version

Available from: Vectorworks 2016